烂泥:python2.7和python3.5源码安装

本文由ilanniweb提供友情赞助,首发于烂泥行天下

想要获得更多的文章,可以关注我的微信ilanniweb

前几天在centos6.6安装ansible时,一直提示python版本不对,导致不能安装。只能手工进行手工安装python,为了以后不再添这个坑,特记录相关的安装过程。

本文以python2.7和python3.5安装为例。

一、安装python2.7

在安装python之前,我们先来安装在进行python编译时,所需要的的各种依赖软件包,如下:

yum -y install xz wget gcc make gdbm-devel openssl-devel sqlite-devel zlib-devel bzip2-devel

clip_image001

依赖软件包安装完毕后,我们来下载pytho2.7源码包,并进行相关的操作,如下:

wget http://mirrors.sohu.com/python/2.7.12/Python-2.7.12.tar.xz

tar -xf Python-2.7.12.tar.xz

cd Python-2.7.12

./configure –enable-shared –enable-loadable-sqlite-extensions –with-zlib

clip_image002

clip_image003

配置完毕后,开始进行编译和安装,如下:

make && make install

clip_image004

如果安装没有正确错误的话,正确显示如下:

clip_image005

二、修改系统默认python版本

centos6系列默认的python版本为python2.6.6,如果我们要修改系统默认的python版本的话,需要进行如下操作。

执行以下命令,对python2.6进行备份,然后为python2.7创建软链接,如下:

mv /usr/bin/python /usr/bin/python2.6.6

ln -s /usr/local/bin/python2.7 /usr/bin/python

此时,我们可以执行python –V命令,如果出现如下错误:

python: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory

clip_image006

需要编辑配置文件/etc/ld.so.conf添加新的一行内容/usr/local/lib,保存退出,如下:

vim /etc/ld.so.conf

include ld.so.conf.d/*.conf

/usr/local/lib

clip_image007

ld.so.conf文件配置完毕后,我们需要执行如下命令:

/sbin/ldconfig

/sbin/ldconfig -v

clip_image008

然后再执行python –V命令,查看python版本如下:

clip_image005[1]

通过上图可以看到系统默认的python版本已经被修改为python2.7。

三、修改yum相关配置

python2.7安装完毕,由于版本的原因可能会导致yum命令不能使用,就需要我们进行相关的配置。

我们需要先把python2.6备份起来,然后再对yum的配置文件进行修改。如果不进行这一步操作的话,执行yum命令将会提示你python的版本不对。

clip_image009

然后再编辑/usr/bin/yum文件,将第一行的#!/usr/bin/python修改为#!/usr/bin/python2.6.6,如下:

vim /usr/bin/yum

#!/usr/bin/python2.6.6

clip_image010

现在执行yum命令已经不会出现错误信息了。

四、python3.5安装命令

在以上三个章节中,我们介绍了python2.7的安装,这章我们把python3.5安装命令贴出来,就不进行详细的介绍了。

安装相关依赖:

yum -y install xz wget gcc make gdbm-devel openssl-devel sqlite-devel zlib-devel bzip2-devel

安装python3:

wget http://mirrors.sohu.com/python/3.5.2/Python-3.5.2.tar.xz

tar -xf Python-3.5.2.tar.xz

cd Python-3.5.2

./configure –enable-shared –enable-loadable-sqlite-extensions –with-zlib

make && make install

修改系统的默认python版本:

mv /usr/bin/python /usr/bin/python2.6.6

ln -s /usr/local/bin/python3 /usr/bin/python

vim /etc/ld.so.conf

/usr/local/lib

include ld.so.conf.d/*.conf

/sbin/ldconfig

python –V

修改yum使用的python版本:

vim /usr/bin/yum

#!/usr/bin/python2.6.6

未经允许不得转载:烂泥行天下 » 烂泥:python2.7和python3.5源码安装

赞 (2)